Kaye Validator Reff Chek -Electrical Noise

Hy guys!

Has anyone ever had a problem Reff Chek the Kaye Validator?
I tried further to ground the unit but there was no difference, the problem continues.
I use T-type thermocouple. Kaye recommend to buy MUX Board, so I wonder if anyone has similar problems, if someone bought maybe MUX Board.



Yes, we have had this issue arise in the past. We did not go down the route of a MUX board (don’t think it was a suggested option at the time). It occured only in conjuction with qualification of the Terminal Steriliser and we pinpointed the ref check error to when the pump kicked in about 8 or so minutes into the cycle. To overcome this issue we leave the Kaye Validator off until this point (not plugged into the powersource), after the pump kicks in, we then plug it in and turn it on and have had no further ref check errors arising. We also move the Kaye Validator away from the unit and have employed the use of longer thermocouples and pressure transducer cable lenghts to allow us to do so.

Hope this is of help.



Thank you for information, but during all cycle i have a problem, so i cant wait for ON/OFF the pumps, valves.

If someone used the MUX Board,please share the impressions and experiences.

Kind Regards.

my team had the exact same issue arise in a recent autoclave validation…we tried EVERYTHING, we’re even lucky enough to have an electrical engineer on the team with many years of expierence…

We tried:
grounding things in different orders/quantity to see if it was a ground loop issue
we tried shielding with thicker aluminum foil on some of the solenoids and other parts (our mechanical room is completely seperate from the controlled environment of the autoclave door…just so ya know)
we tried 3 different kaye units
we tried premium type-t
we tried stranded 28awg, solid 24awg

and the solution we came to was the same as above, start the kaye after our point of issue. Ours was the fast steam/slow steam solenoids activating…so we just waited until we had hit 100*C to turn on the kaye. It worked flawlessly for us. We were skeptical at first, as we like to retain ALL data…but since no data/lethality was lost really…we just went with it and made notes of it in the protocol.

So, if a better solution comes to light…please, someone, keep us all informed!

You could try altering the hertz frequency in the preferences tab of the software first and clearing the engineering log installed on the unit.

consensus seems to the same, as is from my experience. other than a UPS to plug the Kaye in (which does not always work), start the Kaye after chamber is above 100°C, which is when most of the valves are no longer in “full throttle” mode, reducing the amount of EMF/noise

We have this “Reff Check” problem always doing “autoclave validation”, when we have this problem in ours SIM´s card we have water condensate (applying varnish on the end of the thermocouples before calibrating them we don´t have more this problem).

Dear users I decided to help, so you don`t have to pass the same problem as me. Mux Board is solution for Ref Check. Purchased directly from Kaye service. The device should be sent and then perform the calibration. After installation I had no problems with electrical noise.I hope so that this post was of great help.